Domain logins with ip aliasing under Linux

tonnesen at tonnesen at
Sat Jul 25 16:00:22 GMT 1998

I'm having trouble with domain logins under Linux.  I have an ip alias on
my ethernet card on the samba server so that I have a real ip subnet, and
a fake, masqueraded subnet.

eth0 netmask
eth0:0 netmask

If the client machine has a "real" ip address ( everything
works fine, if it has a "fake" ip address ( I get the
following in the nmb log:

   process_logon_packet: Logon from code = 0

And the logon on the client fails with a "Bad password or access to server
denied" message.

I've tried adding:


to the smb.conf file, but I get the same result.

Is this a known problem, or do I have something set up wrong here?  I
could always chuck out the real ip addressses and just use the fake subnet
if I must, but I'm bound to run into a situation where a workstation needs
a real ip address at some point. 

Software Version Info:
   samba 1.9.18p8
   debian 2.0 (kernel 2.0.32)

Steve Tonnesen
tonnesen at
Coast Mountains School District
Terrace, British Columbia, CANADA

More information about the samba-ntdom mailing list