HELP -- upgrade to 1.9.18p8 causing print/disk trouble ..."

Engelbert Roidl eroidl at
Fri Dec 18 13:19:54 GMT 1998

Hello Jim,

I've installed samba-1.9.18p8 some months ago. Everything worked find
till yesterday.
My PCs went in a similar problem as yours.

If I want to connect to a Networkprinter (my samba is the printserver
for the PC)
it takes a verly long time (10 Minutes) till I get any response from my
If I want to print it takes a very long time too to get the dialog with
the right printer.

The strange thing is, that it worked a very long time very find.

Setting up WINS does not help anything.

Do you have any suggestions?
Does anyone have any suggestions?

	Engelbert Roidl

        workgroup = HASCAD
        server string = Samba Server

        printing = bsd
        printcap name = /etc/printcap
        print command = lp -d %p %s
        lpq command = /usr/bin/lpq %p
        lprm command = /usr/bin/lprm -P%p %j
        lpq cache time = 45

        domain master = no 
        wins server =
        local master = no 

        debug level = 3

      browseable = yes
      printable = yes
       public = yes
       writeable = no
       create mode = 0700


Date:   Mon, 20 Jul 1998 11:54:57 -0400 (EDT)
From:   Jim Farrell <jwf at>
To:     samba-ntdom at, samba at
Subject: HELP -- upgrade to 1.9.18p8 causing print/disk trouble ...

I recently upgraded all our site's samba servers to 1.9.18p8, and I seem
be having many strange problems where they didn't exist before. I
made any changes to smb.conf.

The biggest trouble I seem to have is that people can no longer access 
printers ... NT/95 just gives a generic "path to server not available" 
message. Some nodes even have trouble connecting to shares. When the 
PC's browse the network, then can see the server just fine, but often 
cannot browse any shares on the server. Rebooting the PC doesn't help.

I've found that if I configure the WINS services on the PC's, the
often goes away. On NT I set "use DNS for WINS resolution". Once WINS is
properly configured, the PC seems to work fine. smbclient from any 
machine on the network, and on other subnets has no trouble connecting
the samba services at all.

I've never had to use WINS services before on my local PC's .... but I
the samba server up (a long while ago) to serve WINS anyway just in case
people needed it. Now, it looks as if the PC's won't work at all unless
WINS services are enabled. 

The [global] section of my smb.conf appears below .... any pointers/help 
would be appreciated. If I cannot solve this issue soon, I'll have to 
back the server upgrade out and continue running older versions.


-- jim

(IP of this server is

deadtime = 10
domain master = yes
encrypt passwords = yes
guest account = nobody
load printers = yes
log file = /usr/local/samba/var/logs/log.%m
null passwords = no
os level = 60
preferred master = yes
printcap name = /usr/local/samba/lib/printcap
printing = sysv
remote announce =
remote browse sync =
security = user
server string = ablab server
share modes = no
socket options = TCP_NODELAY
strict locking = no
time server = true
username map = /usr/local/samba/private/mapnames
wins proxy = yes
wins support = yes
workgroup = ABLAB

More information about the samba-ntdom mailing list