smbpasswd problems

Daniel Nilsson daniel.nilsson at
Thu Dec 10 07:45:28 GMT 1998


I'm trying out the CVS source 981204 but I'm
getting some trouble with the encryption.

Tested on Debian Linux 2.0 and FreeBSD 2.2.6:

./configure; make ; make install

copied exapmles/smb.conf.default to /usr/local/samba/lib
and commented out the line with encrypt passwords = yes.

ran cat /etc/passwd | mksmbpasswd > /usr/local/samba/private/smbpasswd
and changed permission according to encryption.txt.

executed as root :

omega:/usr/local/samba/bin# ./smbpasswd -D 10 daniel


New SMB password: (entered a simple passwd)
Retype new SMB password: (entered same simple passwd)
startfilepwent: opening file /usr/local/samba/private/smbpasswd
search by name: daniel
startfilepwent: opening file /usr/local/samba/private/smbpasswd
getfileline: skipping comment or blank line
getfileline: skipping comment or blank line
getfileline: skipping comment or blank line
getsmbfilepwent: entry invalidated for unix user root
lookupsmbpwnam: unix user name root
lookupsmbpwuid: unix uid 0
initialising map
lookupsmbpwuid: unix uid 0
endfilepwent: closed file.
endfilepwent: closed file.
Failed to find entry for user daniel.
Failed to change password entry for daniel

Same result for ./smbpasswd -D 10 syd

The last lines in smbpasswd reads:

]:LCT-00000000:Martin Sydstrand,,,
]:LCT-00000000:Daniel Nilsson,,,

This used to work perfectly with samba 1.9.18.
What am I doing wrong ?

I have also tried the smbadduser script but is gives the same result,
a smbpasswd file in which that smbpasswd cannot find the specified user.

Daniel Nilsson (dae at
D. Nilsson Elektronik & Data
Ögonmåttsgatan 3
S-421 36 Västra Frölunda, Sweden
Tel : +46 (0)31-7099970
Fax : +46 (0)31-7099980
Cellular : +46 (0)70 630 67 35

More information about the samba-ntdom mailing list