What have I done!

James Thompson jamest at math.ksu.edu
Tue Dec 8 23:58:01 GMT 1998

Please forgive the long post.

I have a Solaris 2.6 box running the cvs samba code (domain1) from late
october serving 6 nt4.0 boxes (mine, and 5 student offices)  Everything
was running quite nicely until today.  My network has a Solaris 2.5.1 box
that acts as a DNS server, tape backup, Samba 1.x (workgroup2), etc. etc.

I was adding the 2.6 box to the list of clients that could perform backups
when I made a typo in the hosts file on the 2.5.1 machine.  I mistyped the
ip address for my nt samba server so that it pointed to a differnt machine
being used as a web server. 

Now the DNS named records were correct but the NT boxes started using the
invalid entry I had placed in the hosts file :-(  This broke every machine
but my own.  It took me a while to find the error as the problem didn't
show up until hours after I made the changes.  

So my machine still saw the correct cvs samba server, the student office
computers started sending logon queries to the web server.  I fixed the
host file on the DNS server and rebooted the NT machines.  The student pcs
now correctly resolve the ip address for the nt server but still won't
work. They are unable to find the PDC.  My machine works without any

I've tried both restoring the samba dir tree from backup with no effect. 
Since nothing works I went ahead a tried the beta3 code just to see what
would happen(works on my machine, but not on the others)

I'm going nuts here.  I'm sure I'm overlooking the obvious, any

James Thompson    138 Cardwell Hall  Manhattan, Ks   66506    785-532-0561 
Kansas State University                          Department of Mathematics

More information about the samba-ntdom mailing list