Samba NTDOM under solaris 2.6

Jem Atahan jem at
Tue Apr 7 05:08:14 GMT 1998

> Hi Jem,
> Your error message sounds rather familiar: if I translate it into the
german (we're running the
> kraut-ised version of NT 4.0 SP3) it sounds like what I got.
> I've got a similar set-up to you - Solaris 2.6 on a SPARCstation 20 with
NT 4.0 SP3.
> Try having a look at your network settings, in particular your netmask. I
found that my netmask on
> the Solaris box was set to whereas the NT machine had (which is
> correct). Instead of complaining, NT's networking just behaved rather
strangely - sometimes it
> found Samba on the network, sometimes it couldn't be bothered...
> When I changed the netmask on the SPARCstation to what it should be (ie. the
> problems went away and we've now got a running configuration with domain

Hmm, the netmasks on each of the machines match. The NT machine is using a
statically assigned IP address and netmask. I havn't set any other settings.

> By the way, if I may ask a rude question: you have remembered to add a
machine account to your
> smbpasswd file, haven't you? ie.

I ran the smbpasswd -a -m BUG command which inserted a similar line in
private/smbpasswd. The 0080 field had changed to [W], and the userid was
improbably large (I tried substituting another valid uid).

As far as I can tell, the basic IP connectivity is OK. I can't join the
domain, however.

Does anyone have a lvl 20 log from a sucessfull domain connection the could
send me for comparison, as I'm not sure what my logs are telling me...


More information about the samba-ntdom mailing list