Subject: Re: What could cause rsync to kill ssh?

Madhu enometh at
Mon Jun 12 14:27:07 UTC 2023

* Albert Croft via rsync <a51907b3-09c4-e4c1-8de3-31a0922928e2 at> :
Wrote on Sat, 3 Jun 2023 11:52:56 -0500:

> You say, "knocking my ssh session offline on all terminals and it
> blocks ssh from being able to connect again. Even restarting sshd
> doesn't help".
> Questions:
> * Is the network stack on the affected machine still active? (Can it
>   reach other services or systems on the network?)
> * If the network is NOT reachable, does restarting the network stack
>   make a difference?

I think I've seen this problem.  Last month I was transferring the root
filesystem (live, with script which excludes config files and var) from
one gentoo machine A (with zfs) to another B (with ext4), and "ssh
stopped working."

both kernels were 5.10.x - both were running rsync-3.2.3 at this time.

- sshd on B did not crash, and I was able to walk over to the other
  machine and restarted `sshd -D' by hand and i could watch tcpdump on
  both boxes.

- the network still worked. Only SSH to machine B stopped working. I
  cleared all IPTABLES/NFT and made sure there wasnt any problem from
  those things.

- I could connect via ssh to hosts from A to the internet. I could ssh
  from A to localhost or to A to A another local interface . What I
  could not do was connect via ssh from machine A to the sshd process
  running on B. Only the SYN packet goes out and there is no response
  from B.

on A ip r g 192.168.1.<B>
 192.168.1.<B> dev wlan0 src 192.168.1.<A> uid 0

(Luckily i was able to start rsyncd on B and finish the transfer of /
without ssh and without a catastrophe)

After Rebooting machine B, it came up and ssh to it worked like it had
been working for 3 years under the same setup: Machine A was using on
wifi and talks to machine B which is wired, through a d-link wifi
router after adding an IP address on B's wired network to A's wlan
interface. I couldnt figure out what was happening i put it down to
NSA backdoor level stuff in the kernel which had cut me off.

Earlier during "heavy" rsync, over ssh over i would see "stalls" were
not explained by stracing the rsync processes on either end, this would
resume. But In this instance all port 22 packets from A to B got dropped
without either kernel indicating why.

> I ask because I intermittently see what seems to be a similar
> behavior--rsync client (3.2.7) to a remote system with rsync (3.2.3)
> and a 5.11.x linux kernel that occasionally terminates with the linux
> system losing access to the network where restarting the network stack
> doesn't seem to restore access and requires a reboot of the linux
> system in question.
> On 6/2/23 10:44 PM, Maurice R Volaski via rsync wrote:
>> I have an rsync script that it is copying one computer (over ssh) to
>> a shared CIFS mount on Gentoo Linux, kernel 6.3.4. The script runs
>> for a while and then at some point quits knocking my ssh session
>> offline on all terminals and it blocks ssh from being able to
>> connect again. Even restarting sshd doesn’t help. Rsync has
>> apparently killed it. I have to reboot.

More information about the rsync mailing list