[Bug 15163] New: rsync timeout non-effective

samba-bugs at samba.org samba-bugs at samba.org
Mon Sep 5 13:51:40 UTC 2022


            Bug ID: 15163
           Summary: rsync timeout non-effective
           Product: rsync
           Version: 3.2.0
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: P5
         Component: core
          Assignee: wayne at opencoder.net
          Reporter: devzero at web.de
        QA Contact: rsync-qa at samba.org
  Target Milestone: ---

there seem to be circumstances, where timeout param is not effective

if i do

/root/rsync/rsync-3.2.5/rsync -avi --timeout=10 --exclude='/proc'
--exclude='/dev/'  root at /zfspool/backup/

it hangs forever , as soon as rsync tries to traverse some suspended/hanging
/iscsipool on the remote machine (as this results in locked process as it's in
non-interruptible syscall)

if i do
/root/rsync/rsync-3.2.5/rsync -avi --timeout=10 --exclude='/proc'
--exclude='/dev/'  root at /zfspool/backup/

i.e. if i try to rsync the "hung/stalled" directory directly,  i'm getting
proper timeout behaviour:

receiving incremental file list
[Receiver] io timeout after 10 seconds -- exiting
rsync error: timeout in data send/receive (code 30) at io.c(197)
<proper exit and return to shell>

so, apparently there seem to be circumstances where the timeout detection is
not effective

i tried to have a look with strace but don't get a clue what's the problem, as
in both cases rsync gets stuck in /iscsipool

if i run rsync locally on the machine containing the hung/stalled dir, it
behaves like this:

# rsync -av --timeout=1 --dry-run /iscsipool /tmp
sending incremental file list
[Receiver] io timeout after 1 seconds -- exiting
rsync error: timeout in data send/receive (code 30) at io.c(197)
<here it hangs forever, never returns to shell , cannot even ^C or ^Z>

i have seen rsync hang in my scripted backup solution on other situations, e.g.
stale nfs mount etc and since i have a repro-case now, i decided to open a
bugticket for it 

also see https://www.mail-archive.com/rsync@lists.samba.org/msg33555.html

You are receiving this mail because:
You are the QA Contact for the bug.

More information about the rsync mailing list