Rsync just hanging sometimes

Alexander Gribanov sunrisecoder at
Wed Jul 27 21:01:10 UTC 2022

> ср, 27 июл. 2022 г. в 16:55, <Francis.Montagnac at>:
>> On Wed, 27 Jul 2022 13:30:32 +0300 Alexander Gribanov via rsync wrote:
>> > Rsync starts, goes as in the log below and just hangs like this for
>> minutes
>> > or maybe even hours and nothing changes...
>> This may happen when windows is involved.
>> Try to add the --whole-file option.
> Thank You very much, so far it helped to solve the problem...
> In the documentation it is said:
> -W, --whole-file copy files whole (w/o delta-xfer algorithm)
> When I tried just to add the letter "W" to my options, it didn't work, but
> with "--whole-file" it worked...

 Well, it seems that after some files the same problem appears again...
Just sometimes I get on the rsync-client something like "connection reset
by peer" instead of hanging deadly...

Are there any ideas about how to get more debug info in order to
understand, what is the real problem?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the rsync mailing list