osx permission issue

Perry Hutchison pluto at agora.rdrop.com
Sat Mar 28 20:42:09 UTC 2020

Roland via rsync <rsync at lists.samba.org> wrote:
> does somebody know how to circumvent that "extra file access restriction
> feature" introduced in osx some time ago ?

It may not be possible.

Based on experience with FreeBSD, from which much of OSX is derived,
I suspect you may be running into issues with "file flags"; check the
OSX documentation for the chflags system call.  In FreeBSD, I've seen
that same error message when rsync attempts an operation that would
violate chflags restrictions.

> i already tried adding rsync binary to programms with "full disk access"
> privilege ( system-prefs -> security & privacy -> privacy -> full disk
> access)?? , since running as root is not sufficient - but it does not work.

"full disk access" likely refers to the ability to read the disk
directly, bypassing the filesystem.  It's used by maintenance
programs like fsck and fsdb, and by some full-disk backup programs,
but it won't help rsync.

> i want to make sure that every file on osx is getting backup
> i run rsync on linux to remotely backup osx system (via ssh).
> regards
> roland
> rsync:
> readlink_stat("/private/var/folders/_p/ky_w_lyj6ps7jcnkjkl5ss0m0000gn/0/com.apple.routined")
> failed: Operation not permitted (1)
> ...

More information about the rsync mailing list