[Bug 11166] running with -vvv causes a hang

samba-bugs at samba.org samba-bugs at samba.org
Wed Jul 1 13:36:35 UTC 2020


--- Comment #9 from Michal Ruprich <mruprich at redhat.com> ---

current rsync still hits this problem when transferring huge amounts of files.
I am talking tens of thousands. I tried this with some 700k files and it got
stuck at the same place as before. What worked for me was to create a bigger
buffer from the beginning. I set the IO_BUFFER_SIZE from 32*1024 to 128*1024.

I know that this does not make sense for every transfer but maybe it wouldn't
be a bad idea to create a new option that could increase the size of the buffer
from the beginning. If I have a usecase where I know I am going to be
transferring a lot of files and for some reason I need the -vvv or more, I
could just set the message buffer to a bigger value.

Or do you have an idea how to re-write the logging completely?

Thanks for any thoughts on this.


You are receiving this mail because:
You are the QA Contact for the bug.

More information about the rsync mailing list