[Bug 11101] support writing to devices

ogio.spam ogio.spam at gmail.com
Fri Apr 24 08:38:38 UTC 2020

Hello all,
I'm trying to copy a whole block device to another server.

My issue is that I'm not able to write to a block device.
The special file is overwritten by the normal file.

I'm using rsync 3.1.3 on both servers, and I tried some commands:

#rsync --bwlimit=100k  -vvPz --copy-devices  /dev/sdb 
root at
#rsync --bwlimit=100k  -vvPz --copy-devices --inplace   /dev/sdb 
root at
#rsync --bwlimit=100k  -vvPz --copy-devices --inplace 
--devices  /dev/sdb root at

None of the commands worked well for me.

Il giorno dom, 05/04/2020 alle 18.45 +0000, just subscribed for rsync-
qa from bugzilla via rsync ha scritto:
> https://bugzilla.samba.org/show_bug.cgi?id=11101
> Wayne Davison <wayne at opencoder.net> changed:
>            What    |Removed                     |Added---------------
> -----------------------------------------------------------
> --         Resolution|
> -
> --                         |FIXED             Status|NEW             
>             |RESOLVED
> --- Comment #4 from Wayne Davison <wayne at opencoder.net> ---I've
> refined the old write-devices.diff from the patches repo and included
> itfor the upcoming release.
I cannot use the --write-devices option

I cannot understand if the 3.1.3 contain the write-devices option or if
I have to apply this patch.

Can someone help me understanding the problem?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.samba.org/pipermail/rsync/attachments/20200424/45b7c8a4/attachment.htm>

More information about the rsync mailing list