Segmentation fault using rsync client on Android device

Robert Dailey rcdailey.lists at
Tue Nov 5 21:29:45 UTC 2019

I've compiled rsync for my rooted Android (armeabi-v7a, 32-bit) device
using these instructions:

clone_or_update rsync master git://
cd rsync
./configure \
   --prefix=$INSTALL_ROOT/rsync \
   CFLAGS="$CFLAGS -static"
make -j8 && make install
cd -

Best place for instructions to build I could find were here:

I didn't get any compiler or linker errors. It seemed to work.

I copied the `bin/rsync` executable to the device in the `/data`
directory. I then executed this command:

./rsync -vvvvvvvv --stats --progress -rdt rsync://

I get this output:

opening tcp connection to port 12000
Connected to (
Segmentation fault

Not much to go on. I tried running the same command via rsync in
cygwin and it worked fine:

opening tcp connection to port 12000
Connected to (
msg checking charset: UTF-8
sending daemon args: --server --sender -vvvvvvvvtre.iLsfxC . /  (5 args)
ziosk           Ziosk Content Files

Can anyone help me understand why rsync is crashing on Android? Note
that I compiled rsync using the Android NDK (r20). I set up the
environment (CC, LD, etc) to point to the correct toolchain in the
NDK. It's how I build all of my third party libraries as well, so I
know at least as far as the environment goes, it's all set up

Are there dependencies missing that could cause this problem? I did
not provide any dependencies to rsync when I compiled it.

Thanks in advance for any help. I'm stuck.

More information about the rsync mailing list