hard-link reference error when trying to delete

jared list-rsync at legroom.net
Tue Aug 15 20:13:39 UTC 2017

Hello, all.  I've encountered an odd error that I haven't been able to
identify and resolve myself.  Hoping someone here could provide some

I'm using the following command to rsync files between two servers, over
the internet (if that matters), via SSH:

rsync -ahu --timeout=600 --bwlimit=5120 -v -e "ssh -i /path/to/key"
--filter=". /path/to/filter" /path/to/source/ user at remote.server.com:dest

This works perfectly fine.  However, I recently realized that I forgot
to the --delete option, so there are a great number of stale files on
the remote server at this point.

Adding --delete is when I run into my problem:

sending incremental file list
hard-link reference out of range: 105 (10)
rsync error: protocol incompatibility (code 2) at flist.c(769)

The source and destination servers are running the same versions of
rsync, ssh, etc., so I think that last line can be ignored.  The
"hard-link reference out of range" line seems to be the main issue, but
I cannot figure out what would be causing this.  I enabled various debug
options in both rsync and ssh, but I can't find anything in the debug
output that would indicate the problem.  I tried searching, but the only
result I've found outside of source code
(https://github.com/xonsh/xonsh/issues/2134) is for something that seems
unrelated - it's a python project that calls rsync, apparently
incorrectly, resulting in that error.  In my case I'm calling rsync
directly from bash, so the given solution in that bug report doesn't
seem to apply here.

Any suggestions?  I'm stumped, and I really need to figure out how to
clean up the stale files on the remote server as it's running low on
space  I'm happy to provide any additional information regarding debug
logs or whatever if it would help, just didn't want to spam the list
with a bunch of potentially irrelevant information.

Thanks.  Appreciate any and all guidance.


More information about the rsync mailing list