Doubt on usage of rsync for chown of existing folders

Celso de Sousa Junior celso_de_sousa_junior at
Thu Sep 10 23:16:51 UTC 2015

Hi Kevin, 

Thank you very much. I changed my user in the remote machine (su). 

Then, by trying again with rsync but with no modification in the source folder, I see that file ownership continues the same.

Would be possible for rsync to change the ownership in this case (I am not root) ?


     Em Quinta-feira, 10 de Setembro de 2015 20:01, Kevin Korb <kmk at> escreveu:

Hash: SHA1

The syntax looks correct.  However, note that only root can chown.
You must be running rsync on the target end as root for --chown or
- --owner to work.  If you aren't using root access then just run the
target rsync as the user you want the files to be owned by and it will
have no choice.

On 09/10/2015 06:42 PM, Celso de Sousa Junior wrote:
> Hi,
> Please, I am using rsync to synchronize local machine with remote
> machine.
> I already have some files copied. Now I have to change the
> ownership from existing files in the destination folder.
> I tried the following options but it did not worked. Can you please
> help me with other options or alternatives ?
> --perms --chown=user:group --chmod=777 --exclude-from=$EXCLUDES
> -avzi --rsync-path="/usr/local/bin/rsync" -e ssh
> Thanks, Regards, CJ

- -- 
- -*~
    Kevin Korb            Phone:    (407) 252-6853
    Systems Administrator        Internet:
    FutureQuest, Inc.        Kevin at  (work)
    Orlando, Florida        kmk at (personal)
    Web page:  
    PGP public key available on web site.
- -*~
Version: GnuPG v2


Please use reply-all for most replies to avoid omitting the mailing list.
To unsubscribe or change options:
Before posting, read:

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the rsync mailing list