rsync always try change owner and group of symlink in --fake-super mode

Pavel Alexeev forum at
Sun Oct 11 10:17:26 UTC 2015

Hi all.

I long time discover strange to me behavior. If I add --fake-super
option on both sides rsync start always set owner and group of symlink.
What interesting there no error, but it done each time as it has been

Simple reproduce:
$ mkdir rsync.symlinks
$ echo 'file content' > rsync.symlinks/file.itself
$ ln -s file.itself rsync.symlinks/file.symlink

Then try to transfer it on remote host:
$ rsync -apr --links --itemize-changes --fake-super -M--fake-super
rsync.symlinks backup at
cd+++++++++ rsync.symlinks/
<f+++++++++ rsync.symlinks/file.itself
cL+++++++++ rsync.symlinks/file.symlink -> file.itself

And again:
.L....og... rsync.symlinks/file.symlink -> file.itself

I had tried use --rsync-path="rsync --fake-super" instead of
-M--fake-super what unsurprisingly give me same result:
$ rsync -apr --links --itemize-changes --fake-super --rsync-path="rsync
--fake-super" rsync.symlinks
backup at
.L....og... rsync.symlinks/file.symlink -> file.itself

Is it a bug and have worth to fill issue?

With best wishes, Pavel Alexeev

More information about the rsync mailing list