Aw: Rsync differences using NFS & SMB

Simon Wong (Staff) s.wong at
Tue Jul 21 10:30:14 UTC 2015

Hi Rolan,

I should have corrected that, my bad!  It is an NFS client mounting the
NFS server, I.e. nfsClient:/some_dir_mounted_via_nfs


On 21/07/2015 10:20, "devzero at" <devzero at> wrote:

>>Over ssh/nfs
>>rsync -nuvaz --delete /source/ root at
>i don`t see nfs here, i see rsync syncing a local dir via ssh to a local
>dir on the target system.
>does just export NFS shares to other systems or
>are there other NFS shares being mounted there,
>i.e. is rsync writing via SSH to nfsserver:/some_dir_mounted_via_nfs
>> Gesendet: Dienstag, 21. Juli 2015 um 10:48 Uhr
>> Von: "Simon Wong (Staff)" <s.wong at>
>> An: "rsync at" <rsync at>
>> Betreff: Rsync differences using NFS & SMB
>> Hi,
>> I’m having difficulties trying to understand the performance differences
>> between NFS and SMB. I  have used rsync (OS X) over SMB (mounted network
>> storage) and using rsync (OS X) over SSH (NFS mounted storage)
>> From my test, rsync over SMB builds a file list each time comparing
>> modified source/destination, where as rsync over ssh/nfs is incredibly
>> quicker, pretty much instant.
>> During the test;
>> - when running rsync to the mounted storage on Linux, it identified
>> new/deleted files immediately!
>> - When running rsync over SMB, it builds a complete file list and lists
>> each directory before any copy takes place.
>> To the users perception, building the file list (lets say the user has
>> hundreds/thousands of folders) takes some time to run through each
>> directory.  Once the rsync completes the initial copy, on the second
>> rsync, it completes within seconds.  As expected, right?
>> The problem occurs when I unmount and remount the SMB share.  If I run
>> rsync again it builds the whole file list and begins to run through
>> folder”, even if there is nothing to copy!
>> This is not the same behaviour using rsync via ssh over nfs, it doesn’t
>> appear to show "building file list" and immediately informs the user if
>> files are copying or the completion time.  I have tried multiple
>> troubleshooting, even unmounting the the NFS share and clearing the
>> memory in Linux with no success.
>> The commands I have played around with are;-
>> Over smb
>> rsync -uvaz --delete /source /destination
>> rsync -aHEXAx -v --delete --progress --stats --timeout=999 /source
>> /destination  (tried without —progress and —stats, same behaviour)
>> Over ssh/nfs
>> rsync -nuvaz --delete /source/ root at
>> Thanks,
>> Si
>> The University of Dundee is a registered Scottish Charity, No: SC015096
>> --
>> Please use reply-all for most replies to avoid omitting the mailing
>> To unsubscribe or change options:
>> Before posting, read:

The University of Dundee is a registered Scottish Charity, No: SC015096

More information about the rsync mailing list