rsync --delete

Ken Chase rsync-list-m829 at
Thu Apr 16 09:28:12 MDT 2015

problem is he's trying to rsync into the target dir and have the
side effect of delete. so an empty dir would necessarily need to be
in the target of course and thus created there, triggering the quota block.

he tried to avoid this by using device files then 'blocking all device files'
but i think rsync figures out first there's nothing to do, so it just stops
and doesnt do the delete. wonder if --delete-first would help there perhaps.

however, this is a REALLY obtuse way of running rm. unless of course he's
trying to inject some kinda options into a script that can only run rsync
or something wonky like that.


On Thu, Apr 16, 2015 at 11:23:59AM -0400, Kevin Korb said:
  >Hash: SHA1
  >I don't understand what is wrong with rm either.
  >But if you must have an empty directory is there a tmpfs where you can
  >make one?  Is there already an empty one like /var/empty?
  >On 04/16/2015 10:13 AM, Ken Chase wrote:
  >> Wow, it took me a few seconds to figure out what you were trying to
  >> do.
  >> What's wrong with rm?
  >> Also I think trying to leverage the side of disqualifying all
  >> source files just to get the delete effect (very clever but
  >> somewhat obtuse!) risks creating a temporary file of some kind in
  >> the target at the start of the operation, and if you cant even
  >> mkdir then that exceeds disk quota immediately and fails.
  >> /kc
  >> On Thu, Apr 16, 2015 at 12:20:52PM +0300, ????? ?????? said:
  >>> Hi, Rsync.
  >>> I want to help rsink delete a folder with a large number of files
  >>> and folders. Tried this: rsync -a --no-D --delete /dev/null
  >>> /home/rc-41/data/000000000000061/2015-04-01-07-04/ skipping
  >>> non-regular file "null"
  >>> rsync -a --no-D --delete /dev/zero
  >>> /home/rc-41/data/000000000000061/2015-04-01-07-04/ skipping
  >>> non-regular file "zero"
  >>> That's how it turns out rsync -a --delete /empty_folder/
  >>> /home/rc-41/data/000000000000061/2015-04-01-07-04/ But this
  >>> option is not satisfied as if the disk is 100% filled to create
  >>> an empty folder does not work
  >>> mkdir /empty folder/ Disk quota ekstseeded
  >>> Got an error.
  >>> find /home/rc-41/data/000000000000061/2015-04-01-07-04/ -delete I
  >>> know not suitable
  >>> rm -rf /home/rc-41/data/000000000000061/2015-04-01-07-04/ is also
  >>> not suitable
  >>> How to do it differently?
  >>> -- Sincerely, Dugin Sergey mailto: drug at QWARTA
  >>> -- Please use reply-all for most replies to avoid omitting the
  >>> mailing list. To unsubscribe or change options:
  >>> Before posting,
  >>> read:
  >- -- 
  >	Kevin Korb			Phone:    (407) 252-6853
  >	Systems Administrator		Internet:
  >	FutureQuest, Inc.		Kevin at  (work)
  >	Orlando, Florida		kmk at (personal)
  >	Web page:
  >	PGP public key available on web site.
  >Version: GnuPG v2
  >-----END PGP SIGNATURE-----
  >Please use reply-all for most replies to avoid omitting the mailing list.
  >To unsubscribe or change options:
  >Before posting, read:

Ken Chase - ken at 

More information about the rsync mailing list