rsync with 8bit file names?

Henri Shustak henri.shustak at
Thu Sep 18 18:39:44 MDT 2014

>>> When trying to sync my TV folder to a mirror drive, episodes with non-ASCII characters in them cannot be processed by rsync. Anything I can do about this?
>> (Q1) What do you mean by a mirror drive? Is this a RAID1 external enclosure or some sort of softRAID? Or is it just a copy of the TV folder onto another device?
> A copy of the TV folder.

Okay, thanks for confirmation on this point. Have you confirmed that the file system is good on the destination directory. IE : Running Disk Utility to check the file system?

>> (Q2) Is your Drobo's firmware all up-to date?
> Yes

>> (Q3) Have you tried via SMB rather than AFP?
> No, but my understanding is that afp in 10.9 and 10.10 *si* smb.
I do not understand your reply? What is "*si*"?

>> (Q2-1) Have you tried this same setup when booted from another OS (e.g. 10.9)?
> No, I moved my machine to the DP with DP7 at the same time that I added this new external store to mirror my TV folder to.
I would strongly suggest trying this out on a system running 10.9 (not beta software) and seeing if this resolves the problem.

>> (Q2-2) Have you tried this using some other hardware?
> Limited options. I suppose i could move it to a Mac mini that is still running 10.9 to test, but then again, it’s about 15 files I can manually deal with out of 7TB which seems like less trouble that moving hardware around.
Sure, but you have asked for assistance from the rsync mailing list. It would be good to have answers to the following : 
 Is there a problem on 10.10?
 Is there a problem with some of the hardware you are using?

>> (Q2-3) Have you tried coping this specific file over using the Finder (say to the Desktop) and then using rsync to copy it over to that destination drive?
> I copied the file in the finder to the destination, I did not try copying it and the using rsync locally, but I can do that.

I would give that a try and see if it makes any difference. If that resolves the problem then I suspect it is either something to do with the Drobo, 10.10 or even the network?

Hope this helps.

This email is protected by LBackup, an open source backup solution.

More information about the rsync mailing list