rsync filter rules ignored by rsnapshot

Kevin Korb kmk at
Sat Feb 15 08:35:50 MST 2014

Hash: SHA1

I am guessing that the problem is probably related to command line
quoting vs config file settings.

I mainly replied to tell you that if you run with link_dest disabled
you are stuck with the level of performance from 10 years ago.

On 02/15/2014 05:08 AM, Lorenz wrote:
> Hello guys,
> sorry for cross-posting, but imho it could be an error in my
> rsnapshot setup as well as in my rsync setup. If there is a
> solution on one of these mailing-lists i will post it to the other
> one as well. ok?
> here is my question: when running rsnapshot, my exclude filter is
> being ignored, but i don't see why.
> grep -v "#" /etc/rsnapshot-debx40.conf | grep .
> gives
> config_version	1.2 snapshot_root
> /media/extfp/Backup/rsnapshot-debx40/ no_create_root	1 cmd_cp
> /bin/cp cmd_rm		/bin/rm cmd_rsync	/usr/bin/rsync cmd_ssh
> /usr/bin/ssh cmd_logger	/usr/bin/logger retain	daily	7 retain
> weekly	4 retain	monthly	3 verbose		5 loglevel	5 logfile
> /var/log/rsnapshot.log lockfile	/var/run/ 
> rsync_long_args	-ev --rsync-path=/home/backupuser/ 
> exclude	"**no-backup**" link_dest	0 rsync_numtries	1 backup
> backupuser at debx40:/home/lorenz/	home/lorenz/ backup
> backupuser at debx40:/etc/		etc/ backup	backupuser at debx40:/root/
> root/
> rsnapshot -D -c /etc/rsnapshot-debx40.conf daily
> works but e.g. /home/lorenz/testsource/no-backup/some-file
> is also rsynced, despite it would match the exclude pattern in my
> /etc/rsnapshot-debx40.conf
> running the except same rsync command as printed out by rsnapshot
> -tD -c /etc/rsnapshot-debx40.conf daily, namely
> /usr/bin/rsync -av -ev
> --rsync-path=/home/backupuser/
> --exclude="**nobackup**" --rsh=/usr/bin/ssh
> backupuser at debx40:/home/lorenz/
> /media/extfp/Backup/rsnapshot-debx40/daily.0/home/lorenz/
> works and e.g. /home/lorenz/testsource/no-backup/some-file is
> really excluded.
> after hours of fiddling around with filter rules i finally tried
> using an exclude-from file and it worked perfectly. Could the
> failing of the attempt with exclude filters in
> /etc/rsnapshot-debx40.conf be a bug? could this misbehavior be
> related to the problem i posted some days ago (see
> "[rsnapshot-discuss] wondering why backup wont start" or
> "/usr/bin/ssh not found when rsync is executed within rsnapshot" on
> the rsync mailing-list)?
> --
> keep rockin Lorenz

- -- 
	Kevin Korb			Phone:    (407) 252-6853
	Systems Administrator		Internet:
	FutureQuest, Inc.		Kevin at  (work)
	Orlando, Florida		kmk at (personal)
	Web page:
	PGP public key available on web site.
Version: GnuPG v2.0.22 (GNU/Linux)
Comment: Using GnuPG with Thunderbird -


More information about the rsync mailing list