[Bug 10518] rsync hangs (100% cpu)

samba-bugs at samba.org samba-bugs at samba.org
Sun Apr 6 07:47:20 MDT 2014


--- Comment #8 from Eric Chaput <samba at ftd.idms.com> 2014-04-06 13:47:15 UTC ---
I struggled with the same problem trying to rsync a particular large VM file.

Even though your random data trick didn't help it got me thinking about the
issue and I thought couldn't we just increase the blocksize of the delta xfer
algorithm until it chunks it out in few enough pieces?

It turns out that you cannot increase it to more than 128k for protocol version
30, which rsync 3 uses.

Thankfully you can specify which protocol version to use.

I tried 1MB, same problem, cpu hangs on sender at some point, then tried 10MB
and that worked for me (40GB VM img which probably contains 50% nuls). Here are
the command parameters I used:

--block-size=10485760 --protocol=29 

I'm using --inplace too in case that matters, and stock rsync 3.0.7 from debian
squeeze on both ends

Configure bugmail: https://bugzilla.samba.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the rsync mailing list