Problems with directories containing spaces in name

Achim Denzl denzl at
Fri Mar 1 16:57:41 MST 2013

Hi anybody!

I'm not shure if this really is a rsync problem, it might also be a 
shell issue. But hopefully, someone has a hint for me ;-)

I'm using rsync 3.0.9 on two OS X Servers (FreeBSD) to synchronize 
several folders between both servers (2-way-sync). Works fine, with one 
exception: One of the directories to be sync'd contains a whitespace in 
its pathname, and this one only works in one direction and fails in the 

Here's the first one (it's all on one line):

rsync "/Volumes/PromiseRAID/Satz/Akzidenzen 2012/" 
"root at 
2012" 2>&1

This one works fine, no problems so far.

And now, the other way round:

"root at 
2012/" "/Volumes/PromiseRAID/Satz/Akzidenzen 2012" 2>&1

This one throws the following errors:

rsync: link_stat "/Volumes/WD-Daten/XserveMirror/Satz/Akzidenzen" 
failed: No such file or directory (2)
rsync: change_dir "/private/var/root//2012" failed: No such file or 
directory (2)
rsync error: some files/attrs were not transferred (see previous errors) 
(code 23) at main.c(1588) [Receiver=3.0.9]

Both pathes are correct and I could hunt the problem down to the space 
character between "Akzidenzen" and "2012". I tried to escape it with
"\ " and also tried omitting the quotes around the path, but the only 
thing that happened was, that the formerly working command failed and 
the broken one suddenly worked ok. Strange :-/

But somehow, both directions ought to work, and I'm stuck here...

BTW: For better readability, I removed the rsync-options in the lines 
above. They are: -naxuNXzh --timeout=1800 --fileflags 
--partial-dir=.rsync-partial --rsync-path=/usr/local/bin/rsync --stats.

Maybe someone can help...




DTP-Studio DENZL Telefon +49 941 / 44 96 44
Heinkelstraße 1 Telefax +49 941 / 44 96 45
D-93049 Regensburg

More information about the rsync mailing list