rsync 3.0.9 hangs on large file

Voelker, Bernhard bernhard.voelker at
Thu Jan 3 02:29:58 MST 2013

Greg Bell wrote (Thursday, January 03, 2013 6:42 AM):

> Hi Folks,
> Similar to an earlier thread, but slightly more ordinary.  My old 
> rsync backup script, which worked fine under Ubuntu 12.04, hangs on 
> Ubuntu 12.10 (rsync 3.0.9) and a 250 MB file.  Command line as follows:
> rsync      --itemize-changes --human-readable  --progress --delete \
>      --delete-excluded --compress --bwlimit=18 --recursive --archive \
>      --partial --partial-dir=~/partial     --exclude=.cache/
>      --exclude=*/tmp/
>      --exclude=*/cache/
> a few dozen more excludes...
>       /home/gbell2     gbell at moms:backups/gbell_backups_mnt
> Anything jump out at anybody?

A while back, I had also hangs. Well, I was on Solaris at that
time ... Removing --compress from the command line fixed it.

> 22291 read(3, "L\0\0\nrsync error: error in file I"..., 8184) = 169

This looks suspicious to me.

BTW: why do you reduce the bandwidth to such
a low limit (for a LAN)?

Have a nice day,

More information about the rsync mailing list