rsync over ssh hang on error

Justin Pryzby justinp at
Fri Aug 16 19:20:12 MDT 2013

I saw something similar on a solaris machine.  Do you know what kind of
redirection of file descriptors is going on ?  I worked around my
problem by using tempfiles rather than sophisticated redirections [0].


[0] Something like this:
x=` { $ssh -T "$host" zfs send </dev/null |zfs recv; } 2>&1`
ssh -T and </dev/null were earlier attempt to work around the problem.

On Sat, Aug 17, 2013 at 11:49:27AM +1200, Volker Kuhlmann wrote:
> I have an "interesting" problem that I didn't think would ever happen...
> Using rsync over ssh to mirror a local directory on a remote host.
> On the remote host the disk becomes full during the rsync run.
> What I find then is an ssh process on the remote host with no child
> processes, i.e. the remote rsync has correctly terminated, but the shell
> has not. On the lost host, rsync is still waiting for the remote to
> finish. The local ssh client process (a subprocess of the local rsync)
> is still running too.
> What's going on here? I'd be expecting the local rsync to report some
> error and exit on-zero.
> Both systems are openSUSE 12.3, kernel 3.7.10, rsync 3.0.9, openssh
> 6.1p1.
> The local rsync is started from a script that is started by rsnapshot's 
> cmd_postexec facility. (Essentially, I am rsync'ing a local snapshots
> tree to a remote host.) The process worked fine before the remote ran
> out of disk space.
> Thanks for any pointers,
> Volker
> -- 
> Volker Kuhlmann
>	Please do not CC list postings to me.
> -- 
> Please use reply-all for most replies to avoid omitting the mailing list.
> To unsubscribe or change options:
> Before posting, read:

More information about the rsync mailing list