Getting messages "failed to stat" only in cron execution

joop g jjge at
Sun May 6 01:48:27 MDT 2012

On Saturday 05 May 2012 17:46:25 Wayne Davison wrote:
> On Thu, May 3, 2012 at 10:17 AM, joop g <jjge at> wrote:
> > **
> > 
> > Invalid or incomplete multibyte or wide character (84)
> That looks like an OS error.  Are you using a file system that rejects
> invalid character sequences (OS X systems usually have this)?  Check your
> environment variables for differences relating to character sets and
> rsync's iconv option (such as RSYNC_ICONV).
> ..wayne..

It is somewhat complicated. My server runs Linux, and the file system is e2fs, 
which is disclosed to the Windows workstations by Samba.

However, the backup is entirely done in Linux.

I have noticed one difference in environment variables: if I run locale in the 
cron job, I get all language variables set to "POSIX", and if I run it from a 
shell (when it works without messages) all variables are "en_US".
However, when I paste the output from locale under the shell into the batch 
file, I still get those messages!

joop gerritse
Mühlenstraße 11
D-47546 Kalkar-Wissel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the rsync mailing list