[Bug 8177] Problems with big sparsed files

samba-bugs at samba.org samba-bugs at samba.org
Thu Mar 1 03:08:29 MST 2012


--- Comment #8 from Rick <rick at ict-concept.nl> 2012-03-01 10:08:28 UTC ---
Hi Jorge,
You're not alone :)

I'm using rsync the backup some vmware servers. Small files work without any
problems but the large (-flat.vmdk) file only works the first time. (I do
create a snapshot before syncing)

This is the log:
Sync the -flat.vmdk file (Vcenter Server-flat.vmdk)
rsync: read errors mapping
"/vmfs/volumes/4cf36d72-d19e4c8a-cec8-d485645b13ad/Vcenter Server/Vcenter
Server-flat.vmdk": Invalid argument (22)
ERROR: Vcenter Server-flat.vmdk failed verification -- update discarded.
rsync: read errors mapping
"/vmfs/volumes/4cf36d72-d19e4c8a-cec8-d485645b13ad/Vcenter Server/Vcenter
Server-flat.vmdk": Invalid argument (22)
rsync error: some files/attrs were not transferred (see previous errors) (code
23) at main.c(1518) [generator=3.0.9]
Thu Mar 1 10:43:00 CET 2012 FAILED: rsync on Vcenter Server failed (vmdk-flat
file) (0)

Some details:
The both systems are running VMware ESX 4.1.0 build-260247 (Red Hat 5.1).
The filesystem is ext3.
I tried both rsync 3.0.7 and 3.0.9.
The filesize is 80G / 200G (both ESX servers make copies of the other ESX
server. Both ESX servers give the same error)
Removing the --sparse parameter doesn't work

The rsync command used is: /usr/local/bin/rsync -t -e "ssh -i
/operator/vmbackup/vm_image_key -l root" --rsync-path=/operator/rsync --sparse

The backup script runs at multiple customers (some are also ESX 4.1 machines),
but this is the only one giving an error.

Configure bugmail: https://bugzilla.samba.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the rsync mailing list