Rsync to a Remote NAS

Chris Arnold carnold at
Thu Jun 7 17:31:12 MDT 2012

If the NAS is your command on the other side would be:
rsync  --verbose --progress --stats --compress --recursive --times 
--perms --links --delete /Share/

I run this command and get failed to connect to Connection refused. I shouldnt have to open any ports because this is coming across the VPN, right?

Chris Arnold schrieb:
> Forgive me if this has been addressed here before. We have a remote office that we need to backup to our NAS. We have a site to site certificate VPN. The remote site has over 51gb that needs to be backed up to our NAS over that VPN. I have tried this command:
> rsync --verbose --progress --stats --compress --recursive --times --perms --links --delete /Share/* / smb://
> and it just sits there and appears to do nothing. Does rsync make a tarball first and then put it where it is told to put it or does it just copy the files/folders over? Maybe it is the smb://xx.xx.xx.xx/whatever that is breaking it......the bottom line is i need to copy/rsync a directory to a remote server through a VPN. How is this accomplished?

More information about the rsync mailing list