backup to NTFS USB disk

joop g jjge at
Sun Apr 15 02:05:32 MDT 2012

On Friday 13 April 2012 21:22:42 josephj at wrote:
> Since no one has replied yet, I have one idea that *might* point to part
> of your problem.  I've never had to deal with locale issues, so I have no
> idea about that.
> You have directories and file names with blanks in them.  In general, this
> causes a lot of trouble for a lot of programs.  I'm not sure how rsync
> handles them.

It is very kind of you to at least give it a try, but I am quite sure that 
spaces are not the problem. In fact, I have been experimenting further, and 
the situation is even more complicated.

First of all, I have to apologize to the list for my first question, regarding 
> > WARNING: Couldn't set locale to 'nl_NL.iso-9959-1' thus some file names
> > may not
> > 
> >          be correct or visible. Please see the potential solution at
> >

I could try, of course, but it was clearly off-list.

Before I am to present my more complex problem, I might give some explanation. 
I am managing the computer systems for a small regional museum, and we do a 
lot of digitalization (pictures, movies), and of course regular backups, for 
which I use rsync. And we have three backup disks which are regularly changed. 
We are mostly running XP workstations, with a SAMBA server, but the backup 
disks are NTFS.

Currently I am replacing the old 1 TB backups (which are nearly full) with    
2 TB disks. And then I saw a problem re-occeur which I thought I had solved 
before. Not only that, but I also saw it "vanish" this time, rather than being 
solved, as I thought before.

Take the example I gave already.

> > rsync: recv_generator: failed to stat "/mnt/tmp/backup/museum/adlib/adlib
> > documenten voor/catalogus objecten in eigen bezit/artikelen,
> > algemeen/8467 wehrpa\#303\#237.doc": Invalid or incomplete multibyte or
> > wide character (84)
> > rsync: recv_generator: failed to stat
> > "/mnt/tmp/backup/museum/documenten/bestuur/archief, niet
> > geschoond/publiciteit/idee\#343\#253n website.doc": Invalid or incomplete
> > multibyte or wide character (84)

Behind the backslashes you see a numerical code, which is clearly indicating a 
locality problem; in fact the file names are "8467 wehrpaß.doc" (with a German 
"sz" in it), and "ideeën website.doc", with a Dutch "e-trema" in it. Neither 
of these is a problem in Linux, Samba, Windows XP, or NTFS.

So I am pretty sure it _is_ a locality problem, and I had it before, when I 
installed the 1TB disks, and I _thought_ I had solved it.

But now I also discovered that the problem vanishes by itself, when you re-run 
rsync. If you have this "ideeën" file, it is rejected, and it is _not_ saved, 
but if you run rsync again, the message does not appear, and the file _is_ 

This must have led me astray the previous time in thinking that I had solved 
the problem, and it may also be responsible for some of the options I chose 
and which apparently were succesful.

So my question is now: how come a file is rejected the first time around, and 
simply accepted the second time, _without_ any change?

Well, as a system manager I can now be happy, for the problem goes away, but I 
am still interested in the mechanism behind it. My C knowledge is a bit rusty, 
so I am not really planning to go through the source code myself :-)

joop gerritse
Mühlenstraße 11
D-47546 Kalkar-Wissel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the rsync mailing list