Problem syncing to Netapp (rsync: failed to set times on...)

Greg Deback (rsync) greg.deb+rsync at
Mon Apr 9 14:48:26 MDT 2012

PPS. Yet another (a bit ugly) workaround, regarding how often the job is
done : try the options --modify-window=N (N in seconds), to allow timestamp
differences, or/and --size-only (comparing on filesize only).

On Mon, Apr 9, 2012 at 10:32 PM, Joachim Otahal (privat) <Jou at>wrote:

>  I know from a lot of NAS boxes that they tend to use their internal time
> to stamp files instead of the time given by a copy job.
> The easiest way to test is to deliberately set the time off by a few hours
> on the box you monted the stuff on, the NAS and netapp (or the Server
> accessing the netapp) and create a file from your mount point, and check
> whether the time is right.
> cifs isn't the fastest way in unix environments, and samba uses _quite_ an
> amount of CPU power if you are above 50 MB/s.
> If in any way possible you should do it more directly, having an
> in-between box in the network causes (if -c is used) that all files are
> read from both boxes over the network just for the checksum, hence the bad
> performance.
> These Netapps, are they "pure" storage and the server using them is either
> windows or linux? If yes: Put rsync directly on those servers. This also
> applies to most NAS boxes I know, they offer rsync directly, most of the
> time as server.
> Joachim
> BillDorrian at schrieb:
> Hey folks.
> I have a machine that I use as an intermediary to rsync between a NAS in
> another building (the users there have poor bandwidth and need local
> storage) and the our Netapp located in our Datacenter. I get lots of the
> "rsync: failed to set times on..." errors, and files which have already
> been transferred just try to sync again anyway.
> These are the mount options that I use for both sides:
> mount -t cifs -o credentials=/root/.synccreds //nasdevice/folder /nas
> mount -t cifs -o credentials=/root/.synccreds //netapp/folder /netapp
> The ".synccreds" file has the credentials of an Active Directory Domain
> Admin account, which has "Full Control" on both the NAS and the Netapp.
> Here is the command that I run to do the rsync:
> rsync -rvt  --delete --progress /nas/ /netapp/
> Running rsync with "-i" shows that the files are transferring because of
> timestamp differences.
> I tried the "-c" option in place of the "-t", but the server doing the
> sync just hung there for literally two days without anything transferring
> and no output. I realize that the -c option is slower, but yikes!
> Any thoughts? Suggestions?
> Thanks,
> Bill D.
> Bill Dorrian
> Network Administrator
> Desk: 904-273-7625
> Cell: 904-859-9471
> " THE PLAYERS begins May 10 on Golf's Greatest Stadium. For more
> information visit PGATOUR.COM/theplayers."
> "The information contained in this transmission and any attachments may
> contain privileged and confidential information. It is intended only for
> the use of the person(s) named above. If you are not the intended
> recipient, you are hereby notified that any review, dissemination,
> distribution, or duplication of this communication is strictly prohibited.
> If you are not the intended recipient, please contact the sender by reply
> email and destroy all copies of the original message."
> --
> Please use reply-all for most replies to avoid omitting the mailing list.
> To unsubscribe or change options:
> Before posting, read:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the rsync mailing list