Problem syncing to Netapp (rsync: failed to set times on...)

Joachim Otahal (privat) Jou at
Mon Apr 9 14:46:09 MDT 2012

PS: Another (ugly) workaround: Use two linux boxes, place then both on 
each side of the slow line. One side having the NAS mounted + running 
rsync server, the other having the netapp mounted.
Then sync between those two linux boxes. Even if you have to use -c or 
--ignore-times the "full read just for checksum" would only happen in 
the LAN of each networks while the slow line has only the burden of the 
checksums and actual transfers.


BillDorrian at schrieb:
> Hey folks.
> I have a machine that I use as an intermediary to rsync between a NAS 
> in another building (the users there have poor bandwidth and need 
> local storage) and the our Netapp located in our Datacenter. I get 
> lots of the "rsync: failed to set times on..." errors, and files which 
> have already been transferred just try to sync again anyway.
> These are the mount options that I use for both sides:
> mount -t cifs -o credentials=/root/.synccreds //nasdevice/folder /nas
> mount -t cifs -o credentials=/root/.synccreds //netapp/folder /netapp
> The ".synccreds" file has the credentials of an Active Directory 
> Domain Admin account, which has "Full Control" on both the NAS and the 
> Netapp.
> Here is the command that I run to do the rsync:
> rsync -rvt  --delete --progress /nas/ /netapp/
> Running rsync with "-i" shows that the files are transferring because 
> of timestamp differences.
> I tried the "-c" option in place of the "-t", but the server doing the 
> sync just hung there for literally two days without anything 
> transferring and no output. I realize that the -c option is slower, 
> but yikes!
> Any thoughts? Suggestions?
> Thanks,
> Bill D.
> Bill Dorrian
> Network Administrator
> Desk: 904-273-7625
> Cell: 904-859-9471

More information about the rsync mailing list