[Bug 8130] New: ACL and link-dest do not work together

samba-bugs at samba.org samba-bugs at samba.org
Wed May 11 15:59:34 MDT 2011


           Summary: ACL and link-dest do not work together
           Product: rsync
           Version: 3.0.8
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: major
          Priority: P5
         Component: core
        AssignedTo: wayned at samba.org
        ReportedBy: az9901 at gmail.com
         QAContact: rsync-qa at samba.org


I am trying to use ACL and link-dest without success.
Here is what I do.

First step, without ACL :

rsync -ai --link-dest=<date_folder_1> --link-dest=<date_folder_2> /sourcedir

All works fine here, my files are hard linked together, "ls -li" on myserver

Second step, adding ACL :

rsync -aiA --link-dest=<date_folder_1> --link-dest=<date_folder_2> /sourcedir

Each time I run this command, rsync itemizes an ACL change for each file, for
example :
cf.......a. d/Users/Users.txt
However, nothing has changed on the source.

On myserver, "ls -li" confirms that my files are no more hard linked together.
As my rsync daemon has "fake super = yes", I run "getfattr -d" on my files to
compare attributes : same files from differents date_folders have exactly the
same attributes' values (user.rsync.%stat and user.rsync.%aacl).

Seems that --acls is not --fake-super aware.

Thank you very much for your support !

Best regards,


Configure bugmail: https://bugzilla.samba.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the rsync mailing list