ACL and link-dest

AZ 9901 az9901 at
Sun May 8 10:21:23 MDT 2011


I am trying to use ACL and link-dest without success.
Here is what I do.

First step, without ACL :

rsync -ai --link-dest=<date_folder_1> --link-dest=<date_folder_2> /sourcedir myserver::backup/$(date)/

All works fine there, my files are hard linked together, "ls -li" on myserver confirms.

Second step, adding ACL :

rsync -aiA --link-dest=<date_folder_1> --link-dest=<date_folder_2> /sourcedir myserver::backup/$(date)/

Each time I run this command, rsync itemizes an ACL change for each file, for example :
cf.......a. d/Users/Users.txt
However nothing has changed on the source.

On myserver, "ls -li" confirms that my files are no more hard linked together.
As my rsync daemon has "fake super = yes", I run "getfattr -d" on my files to compare attributes : same files from differents date_folders have exactly the same attributes' values (user.rsync.%stat and user.rsync.%aacl).

So why Rsync does not hard link them ?

Env :

Source : Rsync 3.0.8 / Cygwin 1.7 / NTFS
Destination : Rsync 3.0.8 / Debian 6 / ext4 with user_xattr

Thank you very much !

Best regards,


More information about the rsync mailing list