rsync -rcv printing out filenames when content identical

Mikolaj Kucharski mikolaj at
Wed Jan 26 18:41:44 MST 2011

On Thu, Jan 27, 2011 at 12:45:38AM +0000, Mikolaj Kucharski wrote:
> On Wed, Jan 26, 2011 at 09:06:35PM +0000, Mikolaj Kucharski wrote:
> > On Wed, Jan 26, 2011 at 12:48:42PM +0100, Paul Slootman wrote:
> > > On Wed 26 Jan 2011, Mikolaj Kucharski wrote:
> > > > 
> > > > both folders. I run always rsync -n -rcv --delete backup/ mail/ and
> > > > rsync randomly repors that Jira should be synced or not if I run this
> > > > command five times in a row in 1 second interval.
> > > 
> > > Use -i to show what attributes rsync thinks are different, leading to
> > > the sync.
> > 
> > Cool. Thanks for that Paul.
> > 
> > 	rsync -v -n -rc --delete -i backup/ mail/
> > 
> > 	>fc.T......
> > 
> > 	> means that a file is being transferred to the local host (received)
> > 	f for a file
> > 	c means either that a regular file has a different checksum
> > 	T means that the modification time will be set to the transfer time,
> > 	  which happens when a file/symlink/device is updated without --times
> > 
> > Is it possible that rsync(1) can compute different checksum once in a
> > while for a file?
> > 
> > Can I see somehow checksum for each file computed by rsync(1)?
> At the link below you can find outputs from rsync -vvinrc and rsync
> -vvvinrc with --delete option. Strange thing is with -vv Jira is synced
> most of the time, but with three `v's (-vvv) I never managed to get in
> synced. With -vv and without -i rsync says all emails in Jira are up
> to date. Odd.
> You can compare outputs. If you would like to request rsync with any
> other options I can upload them upon request. Unfortunately I cannot
> share my email contents.

It seems that the content of those mails is not important. I've recreated
structure of my backup/ and mail/ directories with *empty* files. rsync
behaves the same and tries to rsync Jira randomly. I've also re-created
directory structure with random content in the files and got as well the
same behaviour.

I'm attaching a tarball with few scripts which create random content and
zero-file-sized content in backup/ and mail/

Can someone explain me why rsync behaves that it tries to sync Jira
folder? For a moment I though I have badrams or something, but I've
tested this on many OSes and different hardware.

PS. Usage:

1. mkdir 0-tmpdir && cd 0-tmpdir
2. get maildirs.tgz
3. tar -zxf
4. sh sh.rsync
5. diff -ruN -x INBOX backup/ mail/
6. sh sh.rsync
7. sh sh.rsync

I've tested above on rsync-3.0.7-3.fc13.x86_64,
rsync-3.0.6-4.el6.x86_64, OpenBSD/i386 4.6 rsync 3.0.6, OpenBSD/i386
4.9-beta rsync 3.0.7 and everyhere is the same problem.

Also tested above on rsync-2.6.8-3.1 RHEL 5.5 i386 and issue is not
occurring there.

best regards
-------------- next part --------------
A non-text attachment was scrubbed...
Name: maildirs.tgz
Type: application/x-tar-gz
Size: 26156 bytes
Desc: not available
URL: <>

More information about the rsync mailing list