MacOS and Extended Attributes

David Allie david.allie at
Sat Jan 1 10:18:22 MST 2011


I've tried your commands at and found that I get errors with two lines:

curl -o patches/crtimes-64bit.diff
curl -o patches/crtimes-hfs+.diff

I'm running 10.6.5 and when I run curl -V, I get:

curl 7.19.7 (i386-apple-darwin10.2.0) libcurl/7.19.7 zlib/1.2.3
Protocols: tftp ftp telnet dict http file 
Features: Largefile libz 

I found that I can manually go to the two https addresses in Safari and paste the contents into the corresponding .diff files using pico, but I'd like to automate the entire process into a script. ANY IDEA on why the curl command isn't working for me with those two lines?


David Allie
Allied CompuTech

On Dec 28, 2010, at 8:17 PM, Mike Bombich wrote:
Hi Dave:

	I put together some instructions for compiling rsync with a few Mac OS X-specific patches here:

Hopefully that gets you going.

On Dec 28, 2010, at 1:49 PM, David Emery wrote:
I'm just starting with rsync().  I grabbed the 3.0.7 source and built it on Mac OS X.6.5 (./configure and ./make reported no problems.)  When I try running with -X or -A, I get the following error messages:
> 	rsync: unpack_smb_acl: sys_acl_get_info(): Unknown error: 0 (0) 
> 	rsync: unpack_smb_acl: sys_acl_get_info(): Unknown error: 0 (0) 
> A quick look at the buglist didn't reveal anything to me, so I don't know if this is a known problem.  (If so I apologize, and ask if there's a workaround.)
> Not using -X or -A does work as expected.
> 		dave

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the rsync mailing list