rsync server: "incoming chmod" usage

rsync at rsync at
Sat Feb 26 05:06:52 MST 2011

> -----Original Message-----
> From: 4wayned at [mailto:4wayned at] On Behalf 
> Of Wayne Davison
> Sent: 17 December 2010 11:31
> To: rsync at
> Cc: rsync at
> Subject: Re: rsync server: "incoming chmod" usage
> On Wed, Dec 15, 2010 at 6:54 AM, <rsync at> wrote:

> I've been meaning to make octal numbers work with --chmod, so 
> I just checked that into git on the master (3.1.0dev).
> 	incoming chmod = Du=rwx,g=rx,o=rx,Fu=rw,g=r,o=r
> Most of those apply to both directories and files, and thus 
> override each other.  I think you want this:
>   incoming chmod = Du=rwx,Dgo=rx,Fu=rw,Fgo=r
> Or, specified another way:
>   incoming chmod = a=r,u+w,D+x
> ..wayne..

Thanks Wayne  :-)

Further to my earlier reply/thanks ...

That worked as expected on Slackware64 13.1 (rsync version 3.0.7) but is not
working on CentOS 5.5 (rsync version 2.6.8).  When running as the default
"nobody", rsync server created directories without the x permission.
Configuring rsync to run as root worked around the problem for rsync server
but did not set "other x".  Now that is needed.  Is there anything to try
apart from building and installing current version of rsync?  



More information about the rsync mailing list