DO NOT REPLY [Bug 7670] rsync --hard-links fails where ditto succeeds

samba-bugs at samba-bugs at
Fri Feb 18 05:38:22 MST 2011

------- Comment #7 from samba at  2011-02-18 06:38 CST -------
I experience the same problem on Linux rsync'ing over the network. Both hosts
uses XFS filesystem(s), both uses Volumegroups that has been lvextended and
then xfs_growfs.

Source uses several smaller LV in different VG (some SSD, some HDD), all XFS
and mounted in various locations.

Destination uses 1 big LV in 1 VG.

rsync source: tried both debian lenny and squeeze packages, 3.0.3-2 and
rsync destination debian lenny package, 3.0.3-2

Kernel source 2.6.32-5-vserver-amd64
kernel destination

Hardware source: Quad-Core AMD Opteron(tm) Processor 2378
hardware destination: Intel(R) Pentium(R) 4 CPU 3.20GHz

df -hi reports plenty of free inodes. Source uses from 1-2%, destination 1%.
There is also several GB left.

Setup: Source is the new server, destination was the old server which is now
redelegated to hotspare (soon to be offsite) to avoid having to restore from
backup if something bad happens.

Will try upgrading destination to squeeze. Upgrading did not work, same result.

rsync command running as root rsync -a -v -P --stats --numeric-ids
--exclude=/dev --exclude=/proc --exclude=/sys root@<servername>:/* .

Configure bugmail:
------- You are receiving this mail because: -------
You are the QA contact for the bug, or are watching the QA contact.

More information about the rsync mailing list