rsync backup problems

Daryl Sayers daryl at
Sun Feb 13 19:27:00 MST 2011

I have FreeBSD 7.3 running rsync 3.0.7. I need to backup a remote server to a
local drive. This remote server has several filesystems types that dont require
backing up, like nfs. If I run the following command:

rsync --delete -azHv myremote:/ /machines/myremote/

It will copy ALL filesystems which is not what I want, so I assume I need to
do it on a per filesystem basis like:

rsync -x --delete -azHv myremote:/ myremote:/usr myremote:/usr/local /machines/myremote/

This worked EXCEPT the /usr/local/ was put into /machines/myremote/local/
and not /machines/myremote/usr/local/. If I do an rsync for each filesystem
then I have problems with the --delete removing the directorys for the
subsequent rsyncs. eg:

rsync -x --delete -azHv myremote:/ /machines/myremote  ; Removes /usr and /usr/local
rsync -x --delete -azHv myremote:/usr/ /machines/myremote/usr  ; removes /usr/local
rsync -x --delete -azHv myremote:/usr/local/ /machines/myremote/usr/local

Is there a way of backing up all the 'ufs' filesystems of a machine onto a
single filesystem destination with a faithful directory reproduction.

Daryl Sayers                             Direct: +612 95525510
Corinthian Engineering                   Office: +612 95525500
Suite 54, Jones Bay Wharf                   Fax: +612 95525549
26-32 Pirrama Rd                          email: daryl at
Pyrmont NSW 2009 Australia                  www:

More information about the rsync mailing list