rsync errors[SOLVED]

Robert Holtzman holtzm at
Wed Sep 22 23:50:03 MDT 2010

On Tue, Sep 21, 2010 at 04:59:39AM -0400, Tony Abernethy wrote:
> Robert Holtzman wrote:
> > 
> > Running Ubuntu 10.04.1 and rsync 3.0.7-1. Used rsync successfully for
> > over a year for backups. Recently there was a kernel upgrade to
> > 2.6.32-25. Don't know if that has any bearing. When I tried to run a
> > backup today rsync failed with the error message:
> > 
> > sending incremental file list
> > rsync: writefd_unbuffered failed to write 4 bytes to socket [sender]:
> > Broken pipe (32)
> > rsync: mkdir "/media/disk/10.04laptop" failed: No such file or
> > directory
> What does
> ls -l /media/disk
> on the target give?  rsync must be able to create (ie write) in that directory.

Sorry to be late with this reply.

I didn't think it was a permission problem and it turned out not to be.
I had renamed the target directory and forgot to change the backup
script. In addition, prior to the upgrade to 10.04, the usb hd showed up
as "disk". After the upgrade it had changed to the UUID and, of course
the script still reflected "disk". Once this was corrected it ran

Many thanks.
Bob Holtzman
Key ID: 8D549279
"If you think you're getting free lunch,
 check the price of the beer"
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: Digital signature
URL: <>

More information about the rsync mailing list