Intermittent rsync Issues

Mac User FR macuserfr at
Thu Sep 16 07:10:56 MDT 2010


Interesting subject. Since a week now I'm trying to solve the same  
problem on a very precise configuration.

In my company we have some wired computers and some wireless ones. All  
of them under Windows XP SP3 with all security updates. They are  
backed up in a FreeNAS box under FreeNAS 0.7.1, so with rsync server  
3.0.7. Clients run under the last cwRsync 4.0.5, so with cygwin 1.7.6  
and rsync 3.0.7. The model rsync command used is:

rsync -aR --link-dest="/lastest" --link-dest="/lastbutone" --link- 
dest="/lastbuttwo" --chmod=ugo=rwX directories_to_backup

All computers backup fine, except one. I suspect a Windows update to  
break some compatibility with it's Netgear WG311v2 PCI wireless card  
(that have crap drivers). In this way, this computer can do anything  
on the network (browse, ftp with large files, imap mail, ...) BUT rsync.

Well, rsync connection is OK. At the start of the command with -vvv  
option I can see it's browsing the hierarchy of files and making hard- 
links of existing files without problem. But, at the first different  
file found, it sends the file (or at least partially, I can see there  
is network activity) and then the network connection drops with error  
12 as Mr Gray. Before error 12 I can see:

rsync: writefd_unbuffered failed to write x bytes

and then

Connection reset by peer (104)

I read somewhere that the ssh connection was stronger than rsync one  
in unstable networks. And effectively, if I run rsync via ssh ( -e  
option), the transfer happen without errors, on the same computer  
using the same networking setup.

So, I'm now fighting with key pairing between the wireless host and  
the server to do the rsync backup in batch mode without the need of  

I would like to know, if anybody knows, why the ssh connection is more  
robust to network problems than rsync protocol and if it would be  
possible to make rsync more "network problems proof". I have nothing  
against ssh, but I don't need a secure tunneling in my lan. Plain  
rsync would be far simpler for me.

Hope J. T. Gray can profit from my experience that isn't far from his.

Best regards,


Le 15 sept. 10 à 21:10, J. T. Gray a écrit :

> Greetings,
> I posted this to a couple online forums already am am already  
> doubting anyone will be able to directly help me solve my problems.   
> So I am here to query the experts directly:
> I have a number of rsync clients trying to connect to an rsync  
> server routinely, and they're intermittently failing with one of a  
> couple error messages.
> Either:
> 2010/09/15 13:45:23 [32143] rsync: connection unexpectedly closed (0  
> bytes received so far) [Receiver] 2010/09/15 13:45:23 [32143] rsync  
> error: unexplained error (code 255) at io.c(601) [Receiver=3.0.7]
> Or:
> 2010/09/15 13:40:01 [7617] rsync: connection unexpectedly closed (0  
> bytes received so far) [Receiver] 2010/09/15 13:40:01 [7617] rsync  
> error: error in rsync protocol data stream (code 12) at io.c(601)  
> [Receiver=3.0.7]
> The current version of the rsync command I'm using is:
> rsync --rsync-path="/usr/bin/rsync" --stats --compress --times -- 
> links --log-file=/home/ubuntu/rsynclog.txt --exclude thatfile -- 
> recursive /home/ubuntu/ 
> utility_scripts &
> I previously had --verbose and --progress but removed them after  
> reading on another forum that someone had resolved some latency  
> issues by removing those options. I've also tried this command in  
> the form of a shell script, thinking perhaps the issue was that my  
> rsync client was attempting to reuse an expired ssh connection. To  
> that end, it fails seemingly at random whether using rsh or ssh. It  
> periodically fails whether or not I do --del or --delete, --compress  
> or not, --rsync-path or not.
> I cannot get the command to fail from the command line, but when it  
> runs every minute, it fails 5-15 times an hour, depending on the  
> directory being rsync'ed. The permissions and ownership appear to  
> all be correct, and I'm not relying on any sort of environmental  
> variables that would be causing the cron to fail. All of the  
> relevant software packages (bash, rsync, ssh, Linux) are up to date,  
> all key ports are open, and all clients do not fail simultaneously,  
> suggesting this is not a server-side problem.
> If anyone has any constructive feedback for resolving or  
> troubleshooting this/these issue/s, I am very interested in hearing  
> it.
> Thanks,
> -- 
> Please use reply-all for most replies to avoid omitting the mailing  
> list.
> To unsubscribe or change options:
> Before posting, read:

More information about the rsync mailing list