Another cygwin/rsync question

Henri Shustak henri.shustak at
Mon Jan 18 12:44:08 MST 2010

> I'ts a simplistic backup using rsync from a Windows 2k3 machine to a Linux box out on the 'net, using pre-shared ssh keys. In this case I'm saving, files belonging to various users, using the administrator account on the windows machine and the destination is a normal user account and its home file area. I'm using the rsync --chown option to stop rsync trying to change the ownership/mode on the destination filesystem. I'm not bothered about saving the file perms/ownership.
> If I do a small transfer of a couple of dozen files as a test, all goes well.
> The path of the source on the windows system has spaces in the name, I've tried every type of escaping that I can think of to get the shells to work properly. If I run rsync running on a larger batch of files it seems to stall. Using the -vvv option I can see rsync, on the windows.cygwin end, collecting a list of files prefixed by
> [sender] make_file (filenames)
> that I guess it is going to transfer and then this is followed by
> recv_file_name (another filename)
> Which I presume is the first file that it is transferring. That file is a few hundred k so it won't take long, But rsync stalls at that point. Cntrl C does nothing and I end up having to kill the rsync process.
> I've tried
> rsync -avvvvz --progress --delete --chmod=ugo=rwX -e "ssh -i /home/administrator/rsync-key" """"/cygdrive/c/Users Shared Folders"""" """"user at remotehost/home/user/backup/""""
> rsync -avvvvz --progress --delete --chmod=ugo=rwX -e "ssh -i /home/administrator/rsync-key" """"/cygdrive/c/Users\ Shared\ Folders"""" """"user at remotehost:/home/user/backup/""""
> rsync -avvvvz --progress --delete --chmod=ugo=rwX -e "ssh -i /home/administrator/rsync-key" '"/cygdrive/c/Users\ Shared\ Folders"' '"user at remotehost:/home/user/backup/"'
> rsync -avvvz --progress --delete --chmod=ugo=rwX -e 'ssh -i /home/administrator/rsync-key' /cygdrive/c/Users\\\ Shared\\\ Folders user at remotehost:/home/user/backup/
> The cygwin rsync is v3.0.6 and the Linux (Centos) target machine has rsync 2.6.8

Ken, I am not sure I am able to help you with this problem. However, it sounds like you have quite a lot of experience with rsync and cygwin. The LBackup project <> currently has no one maintaing cygwin compatibility. If you have a look at the LBackup project and are interested in helping out then just let me know. Your assistance would certainly be welcomed.

That said, I have a couple of suggestions :

 (1) Are there any files or directors being backed up which 
     have non-asci characters in the names? Also, have you
     tired removing the parts of the path with spaces or
     tired the rsync on a directory which has no spaces?

 (2) If you use a password rather than public key for
     authentication will it work?

 (3) If you bypass SSH and setup an rsync server on the backup
     source will it work.

Beyond that I am not sure. Hopefully someone else on the list will be able to assist you with some better suggestions.

This email is protected by LBackup, an open source backup solution. 
Free as in freedom; LBackup is licensed under the GNU GPL
Download LBackup now :

More information about the rsync mailing list