rsync/cwgwin hangs during transfers

Alan C. Bonnici chribonn at
Mon Jan 18 01:37:06 MST 2010

I have set up a test system running just OS, cygwin and rsync. Oddly enough
some sites work while others don't. For at least two years the older version
(1.5) of cygwin worked flawlessly.

-----Original Message-----
From: Adam Rosi-Kessel [mailto:adam at] 
Sent: 16 January 2010 20:55
To: rsync at
Subject: Re: rsync/cwgwin hangs during transfers

Steven Monai wrote, on 1/16/2010 2:30 PM:
>>>> Rsync 3.0.7 and Cygwin 1.7.1 hangs at random instances. This does not
>> I have antivirus software (eSet), but it worked fine with Cygwin 1.5.x.
>> I don't have rights on this machine to toggle virus software settings,
>> unfortunately.
> ESET's NOD32 is on Cygwin's Big List of Dodgy Apps (BLODA):

Understood; but regardless it seems like a cygwin/rsync regression that 
it worked fine with the earlier version and no longer does. A lot of 
folks have antivirus software, and some of them have no rights to alter 
the configuration of that software.


More information about the rsync mailing list