rsync/cwgwin hangs during transfers

Max Arnold lwarxx at
Sat Jan 16 22:14:01 MST 2010

On Sat, Jan 16, 2010 at 02:55:06PM -0500, Adam Rosi-Kessel wrote:
> Understood; but regardless it seems like a cygwin/rsync regression that 
> it worked fine with the earlier version and no longer does. A lot of 
> folks have antivirus software, and some of them have no rights to alter 
> the configuration of that software.

Have you tried to roll back to previous version?  Please note that firewall software often
"trained" to allow access for specific programs and after upgrade these settings can be lost.

In my case I even didn't touched anything - freshly installed cwRsync worked fine, but after an
hour or two it just refused to perform either local or remote synchronization.

Two things to check:

1. try it on another machine with same OS version but without any security software
2. or, ask your sysadmin to temporarily disable AV/firewall just to verify possible cause

More information about the rsync mailing list