rsync problem with cygwin 1.7.?

Wiesner Thomas thomas at
Mon Apr 19 13:27:18 MDT 2010

My laptop runs XP Home SP3 and my workstation XP Prof. SP3.

I use Cygwin and rsync to sync my files to a Debian 4.0 server which 
runs rsync 2.6.9 in daemon mode.

It had always worked quite will until I upgraded to Cygwin 1.7.x
(the laptop runs Cygwin 1.7.4 and the workstation 1.7.5 with rsync 3.0.7)

I use
rsync -av --progress --delete foouser at
to sync the changes on the server down to a client.
(There are over 30e3 files to sync.)

If foo_user_files is empty and rsync has to copy all the files
it stops after maybe 50...200 files at an arbitrary file. (No disk 
activity, no network acttivity, nearly no CPU usage.) It just ceases 
copying and after some time (seconds to minutes) it copyies another some 
files until it stops again.
Well, copying/syncing all the 30e3 files would take forever.

The problem may be related to the following post:
Which is the only hint I've found but doesn't show how to solve the problem.

I tested the connection with an Ubuntu installation to make sure that 
the rsync server is ok and it works like a charm there.

I've just set up a network drive and tried "disk"-to-disk sync on the 
client side, but it seems to stall after about 9000 transfers, too.
Interestingly it seems to stall always at the same files with this test 
setup and the transfer rate goes down from some MB/s to some kb/s. Very 
(I don't know if this is rsync's fault or there's some problem with 
samba or XP or..., but it may be a hint. Maybe it is another story.)

I can use strace if you tell me where to put the output, or something 
else you want me to try, because if I don't find a solution, I'll have 
to find another way to sync my files, because Cygwin 1.7 seems to have 
rendered rsync totally useless to me.

Should I have sent this to a Cygwin mailing list instead (or too)?
Well, I don't know.

   mfg Wiesner Thomas

More information about the rsync mailing list