rsync with --link-dest=DIR

Martin rsync at
Sun Apr 18 13:20:36 MDT 2010


thank you for your feedback.

>> The way to troubleshoot this is to pass -i to see why rsync decided not
>> to hard-link the files.

In the meantime I had this idea myself when saerching the web for helpful information.
I was just going to post the result.

For some reason the group of many of the files in the source was set to "admin".
As a "normal" user I was not allowed to set the group of the files in the backup destination to "admin" so the group was set to staff.
The rest is obvious.
Changing the group of the files in the source to staff solved the problem.

For testing with a "local" destination folder copied some of the problematic files to a test directory with the Finder.
This, of course, set the group to staff, too. So everything worked fine and I was convinced that the destination on the external drive was the problem.

Thanks also for your other hints.

Best regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the rsync mailing list