Rsync checksum false negative's

Darren Besler drb at
Fri Mar 20 13:48:22 GMT 2009

I am using rsync 3.0.2 on a Solaris x86 platform to sync about 700GB of
content to an external USB HDD. Both source and destination filesystems are
ZFS so the ZFS metadata holds checksums to validate the on disk data.

I will occasionally run sync in dryrun mode with checksum's and when I do I
will get files reported to copy that haven't changed. Recently, of 3 files
reported, using a manual MD5 hash calculation, 1 file on the ext HDD
reported a different checksum (which I recopied), and 2 files had matching
MD5 hash's. Of the 2 files that did not have to be recopied, a rerun of
rsync did not produce the same result.

The occurrence of the false negative typically happen's on larger files, and
after a new population of the ext HDD.

I would assume the same byte stream should produce the same result
repetitively. Since the ZFS metadata doesn't indicate corruption at the disk
level, I am a little confused as to what could be causing the mismatch's.

Any comments?


More information about the rsync mailing list