--log-file-format seems to be ignored?

Jake Wilson jake.e.wilson at gmail.com
Fri Mar 13 15:30:26 GMT 2009

I'm using Rsync 3.0.5 between two Debian boxes.  I have an rsync
script setup that uses --log-file=mylogfile.log and also I have
specified --log-file-format=whatever.  But I can't seem to get the
--log-file-format to be recognized.  I don't get any sort of errors,
but the log format that I get is just the default, no matter how I
change the format option.

Just for simplicity's sake, I first tried

--log-file-format="%t %f"

Which (according to the man pages) should simply write a line with the
date/time and then the filename that is synced.

Am I doing something wrong?  Is it not supposed to be in quotes?  Is
it supposed to be in parenthesis?  I have tried many different
combinations of things and I just can't seem to get my log files to be
formatted in anything but the default.

Also, at one point I thought, oh well maybe specifying the log format
only applies toward the default log that rsync saves which is
specified in the rsyncd.conf file.  But on these Debian boxes, I can't
seem to find an rsyncd.conf anywhere.  They are web servers for my
company, not my own boxes, so its a little bit unfamiliar to me.  All
I know is that 'locate rsyncd.conf' does not return any results.


More information about the rsync mailing list