Question on "Resource temporarily unavailable" error

Rob Bosch robbosch at
Tue Sep 30 20:20:40 GMT 2008

I'm using rsync over an ssh tunnel to transfer some large files.  I've been
getting the "Resource temporarily unavailable" in my rsyncd.log frequently.
The connections are T1's and very stable so I don't think it is a network
drop.  The disconnect occurs on the same files every time...although these
files are also the largest ones taking the most time.  I tried limiting the
bandwidth to make sure that wasn't an issue and still get the error.  I'm
running rsync on cygwin 1.7.  rsync version is 3.0.3 with preallocate patch
applied.  Anyone have any suggestions?

Example error in rsyncd.log

2008/09/30 12:09:55 [12508] rsync: write failed on "/EDrive/testfile.edb"
(in Test.Backup):Resource temporarily unavailable (11)
2008/09/30 12:09:55 [12508] rsync error: error in file IO (code 11) at
receiver.c(321) [receiver=3.0.3]
2008/09/30 12:09:55 [12508] rsync: connection unexpectedly closed (86 bytes
received so far) [generator]
2008/09/30 12:09:55 [12508] rsync error: error in rsync protocol data stream
(code 12) at io.c(644)


More information about the rsync mailing list