rsync hanging at "generate_files phase=1"

Gavin McCullagh gavin.mccullagh at
Tue May 27 12:20:55 GMT 2008


On Fri, 21 Mar 2008 11:45:20 +0100 Daniel Maher wrote:

>> I am experiencing a (consistent, reproducible) condition whereby rsync
>> is hanging indefinitely at the following stage :
>> generate_files phase=1

> Eschewing the 2.6.9 that ships by default on Cygwin, I compiled Matt's
> patched rsync 3.0.0 by hand and moved forward with that binary.  After
> trying a few more scenarios - and hanging each time at the same phase
> noted above - i tried the --whole-file switch (copy files whole), which
> solved the problem nicely.

I think I'm seeing the same issue. I'm also using Cygwin (on Win Server
2003).  From a linux server I've run

  rsync -a --del --rsh='ssh -l backups' backups at windowshost:/cygdrive/d/webapps/backups webapps/

and it would freeze midway through the transfer of large (~1GB) files
(apparently always at a different point in the file).  As suggested, I've
added -W and all seems to be well now.  

That extra switch doesn't bother me too much, but does anyone have ideas
how to track down this issue?  Is there some information I could provide to

Thanks in advance,

PS I've also since added "-t --modify-window=2" to help avoid
re-transferring data, but that's another story.

More information about the rsync mailing list