3.02 bug? Symlink ->foo changed to ->/rsyncd-munged/foo

Gerben Wierda Gerben.Wierda at rna.nl
Sat May 24 12:44:33 GMT 2008

On Mac OS X 10.5.2 I run rsync to keep a couple of instances of my / 
usr/local tree in sync. With Apple's rsync I run (e.g.):

sudo /usr/bin/rsync --rsync-path=/usr/bin/rsync -E --progress -avu -- 
delete --dry-run  --exclude=TeXLive-working-copy/ --exclude=context- 
update/ --exclude=.Spotlight-V100/ --exclude=.fseventsd/  \
		-e "ssh -i /Users/gerben/.ssh/id_rsync -l root" \
			""/usr/local/gwTeX-new/ \

I installed rsync 3.0.2 recently to try out if I can get rid of th  
efact that Apple's rsync syncs metadata even if they have not changed,  
So i installed it on source and destination machine, On the  
destination machine, my ssh authorized_keys contains

command="/usr/bin/rsync --server --daemon .",no-port-forwarding,no-X11- 
forwarding,no-agent-forwarding ssh-dss etc. etc.

which I change to

command="/usr/local/bin/rsync --server --daemon .",no-port- 
forwarding,no-X11-forwarding,no-agent-forwarding ssh-dss

if I want to run the new rsync. On the client I then run

sudo /usr/local/bin/rsync --rsync-path=/usr/local/bin/rsync -H -A -X - 
e ssh -avu --progress --delete --dry-run --exclude=TeXLive-working- 
copy/ --exclude=context-update/ --exclude=.Spotlight-V100/ -- 
exclude=.fseventsd/  \
		-e "ssh -i /Users/gerben/.ssh/id_rsync -l root" \
			""/usr/local/gwTeX-new/ \

The result of this was that rsync started to sync symlinks that were  
unchanged and what is worse it damaged them in the process:

On source and destination machine to start with:

hedwig:~ gerben$ ls -l /usr/local/gwTeX-new/bin/powerpc-darwin/mex
lrwxrwxrwx  1 501  staff  6 May 19 01:55 /usr/local/gwTeX-new/bin/ 
powerpc-darwin/mex -> pdftex

After running rsync 3.02 on the target machine:

bash-3.2# ls -l /usr/local/gwTeX-new/bin/powerpc-darwin/mex
lrwxrwxrwx  1 sysbh  staff  21 May 19 01:55 /usr/local/gwTeX-new/bin/ 
powerpc-darwin/mex -> /rsyncd-munged/pdftex

After repairing with stock Mac OS X rsync:

bash-3.2# ls -l /usr/local/gwTeX-new/bin/powerpc-darwin/mex
lrwxrwxrwx  1 sysbh  staff  6 May 24 14:31 /usr/local/gwTeX-new/bin/ 
powerpc-darwin/mex -> pdftex

This looks like a bug to me.


More information about the rsync mailing list