rsync hang at end

Lawrence D. Dunn ldunn at
Fri May 23 13:51:41 GMT 2008

   Perhaps unrelated, but I had a hang-at-end situation which at least
   sounds similar.  I tried to use a 3.0.x binary which had been compiled
   on a PPC, on an intel-mini;  it seemed to hang at the end.
   Recompiled on the intel-mini, no problem since then.


At 9:57 PM -0400 5/22/08, Robert DuToit wrote:
>Hi All,
>   My wrapper application for rsync 3.0.2 on osx has been working 
>smoothly except for reports of it hanging on the last file of the 
>transfer to a local firewire drive. We seem to have solved the 
>mystery of the slow transfers  but now, every four or five runs, it 
>hangs at the last file to transfer and refuses to quit. Activity 
>Monitor shows three rsync processes all at 0%CPU at that point (and 
>virtual memory allocated of 3.74GB, 2.6GB and 2.6GB!). The last file 
>incidentally is /usr/standalone/bootx.xcoff
>My friend is using the standard options
>-aHAXN --fileflags --force-change   --stats -v --progress
>on an Intel mac copying his system of 100GB, or 1 million files, to 
>the external drive. As I said, it works well and always copies all 
>of the files perfectly. When the hang occurs, the output shows 
>nothing unusual - it just stops at the last file transferred and 
>does not proceed to shut itself off. We havn't managed to run with 
>-vvv when this happens but will try to catch it with that now. I 
>should also mention that rsync is launched via do shell script and 
>the output sent to a log file in /tmp which the app reads progress 
>I googled around and found references to an rsync end hang that said 
>the child process wasn't getting the quit signal from parent 
>rsync.... (on rsync 2.5.5)
>Don't know if that is relevant at all...
>Any thoughts, anyone?
>thanks so much for this great tool!
>Rob D
>Please use reply-all for most replies to avoid omitting the mailing list.
>To unsubscribe or change options: 
>Before posting, read:

More information about the rsync mailing list