rsync hanging at "generate_files phase=1"

Daniel Maher dma+rsynclist at
Mon Mar 31 09:23:15 GMT 2008

On Fri, 21 Mar 2008 11:45:20 +0100 Daniel Maher
<dma+rsynclist at> wrote:
> I am experiencing a (consistent, reproducible) condition whereby rsync
> is hanging indefinitely at the following stage :
> generate_files phase=1
> The condition does not occur if --dry-run is specified - only when the
> run is "for real".  Finally, i can scp the files without problems, so
> it is not a general connection issue, nor is it a problem with
> permissions (everything is running via sudo in any case).

In case anybody is interested, here's my follow-up to this issue :

Eschewing the 2.6.9 that ships by default on Cygwin, I compiled
Matt's patched rsync 3.0.0 by hand and moved forward with that binary.
After trying a few more scenarios - and hanging each time at the same
phase noted above - i tried the --whole-file switch (copy files whole),
which solved the problem nicely.

Now, of course, i'm not sure /why/ that worked (which is to say that
i'm not sure why the algorithm was failing), but there you go. :)

Daniel Maher <dma AT>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url :

More information about the rsync mailing list